WordPress Plugin: NextGEN Gallery Z Cropper


Das Wordpres Plugin: NextGEN Gallery Z Cropper ist entstanden, da WordPress mit dem NextGEN Gallery Plugin bisher nur das automatische Beschneiden der Bildervorschau (Thumbnails) erlaubt. Die eigentlichen Bilder werden nur verhältnismäßig verkleinert bzw. vergrößert, aber nicht beschnitten. Mit dem Z Cropper gibt der Benutzer vor dem Upload die Zielhöhe und Zielbreite des Bildes an. Während des Uploads wird der maximal mögliche Bildausschnitt aus der Bildmitte auf das angegebene Zielformat gebracht (siehe Screenshot oben). Die hochgeladenen Bilder können anschliessend mit allen anderen NextGEN Plugins verwendet werden. (Voraussetzung: Z Cropper benötigt das NextGEN Gallery Plugin)

Download the Plugin NextGEN Gallery Z Cropper and if you like it


The WordPress Plugin: NextGEN Gallery Z Cropper was programmed, because the NextGEN Gallery Plugin only allows to crop thumbnails on upload. The images are just resized in respect to their ratio. Using the Z Cropper Plugin the user can set a target size: width and height. While uploading the original image will be resized and cropped out of the middle to fill and fit the target size (see the screenshot above). The uploaded images can be used with all other NextGEN Plugins. (Requirements: Z Cropper requires the NextGEN Gallery Plugin installed)


After installation / activation, setup the Z Cropper
(1.) Go to Gallery Options
(2.) Select Images Tab
(3.) Set target width and height
(4.) Disable NextGEN’s auto-resize option

 

4 Antworten auf WordPress Plugin: NextGEN Gallery Z Cropper

  1. Pingback: New Plugin: NextGEN – Z Cropper by vogelundstrauss | The WordPress C(h)ronicle

  2. Lery-la-fléche sagt:

    Hello,
    I’m getting some trouble with your plugin :

    Warning: require_once(/var/www/vhosts/domainname.com/subdomains/abyssin/httpdocs/wp-content/plugins/nextgen-zcropper/simpleimage.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/domainname.com/subdomains/abyssin/httpdocs/wp-content/plugins/nextgen-gallery-z-cropper/nextgen-zcropper.php on line 29

    Fatal error: require_once() [function.require]: Failed opening required ‘/var/www/vhosts/domainname.com/subdomains/abyssin/httpdocs/wp-content/plugins/nextgen-zcropper/simpleimage.php’ (include_path=’.:.:’) in /var/www/vhosts/domainname.com/subdomains/abyssin/httpdocs/wp-content/plugins/nextgen-gallery-z-cropper/nextgen-zcropper.php on line 29

    I didn’t pay attention were I should report error, so I came here…
    Hoping it will work again soon ;)
    It may be because I use a french-translated version of NextGEN Gallery ??
    I don’t think so…

    Regards,
    Lery

    PS : Wenn Sie mir beantworten wollen, können Sie es entweder auf English oder auf Deutsch machen, es ist mir egal.
    Ich verstehe sehr gut Deutsch, da ich in der Schweiz lebe und es bis zu ein relativ gute Niveau gelernt habe…

    • markus sagt:

      Thanks for your time and feedback.
      Sorry i made a mistake when uploading my latest version to the repository.
      Still i don’t know why wordpress plugin system has a problem with my long(?) foldername “nextgen-gallery-z-cropper”

      Anyhow here’s a Quick fix for your problem:
      1. Just rename the plugin-folder to “wp-content/plugins/nextgen-z-cropper/” and
      2. change the 2nd line of code inside “wp-content/plugins/nextgen-z-cropper/nextgen-zcropper.php to
      require_once( WP_PLUGIN_DIR . ‘/nextgen-z-cropper/simpleimage.php’);

      It should work then…
      Good luck and let me know if it worked out for you,
      markus

    • markus sagt:

      fixed the issue now.
      just reinstall the plugin, thanks for your feedback!